Problem
When trying to sign into the HCP portal with SSO configured for the HCP organization, you may run into the "Unable to proceed with request" error message.
Cause
This error is caused by a misconfigured certificate or a invalid ACS URL.
Solutions
Mismatch of the certificates
Please make sure the certificates match. Check to make sure that there is not an extra space at the end or any extra character added while setting up the certificate.
Invalid ACS URL
While we provide a "SSO Sign-On URL" in the "Initiate SAML Integration" instructions, some IdPs receive the request at a path which omits the "?connection=HCP-SSO-[HCP-ORGID]-samlp" argument. Please try to use this URL instead for your ACS URL in your IdP settings:
- https://auth.hashicorp.com/login/callback
Additional Information
For more information about HCP SSO, please review our documentation here.