Problem
User gets a blank screen with the message "Unable to proceed with request" from url:
https://flow.idp.hashicorp.com/login/callback?error=access_denied&error_description=Invalid%20thumbprint%20(configured%3A%20D994292775296E30185D819A5C4265F255744CE2.%20calculated%3A%20A566514D77821C6D757435C248D5C8A63DC60933)&state=1c61242d655a4ec3ae62cc216d5555ab
as shown in the below screen:

Cause
This error is caused by a mismatch of the certificates. The certificate set up in HCP configuration and the SSO provider certificate.
Solution
Please make sure the certificates match. Check to make sure that there is not an extra space at the end or any extra character added while setting up the certificate.
Additional Information