Problem
The customer receives the following problem while completing vault upgrade, which is normal and does no harm.
{"time":"2023-10-16T13:09:03.48293708Z","type":"response","auth":{"token_type":"default"},"request":{"id":"92577127-83ff-85ab-40c3-
406b25e9f7b9","operation":"update","mount_point":"auth/approle/","mount_type":"approle","mount_accessor":"auth_approle_eaf3d9fb","namespace":
{"id":"root"},"path":"auth/approle/login","data":{"role_id":"hmac-sha256:15940b5d7ca130b47afcbdf226da10ab72cf5afa1c9605a75d9731415e892c90",
"secret_id":"hmac-sha256:e9c8af64a64cb9bb28de961ff784fd34d969915539ffbcedf95d79851e98075d"},"remote_address":"10.168.112.36","remote_port":54824},
"response":{"mount_point":"auth/approle/","mount_type":"approle","mount_accessor":"auth_approle_eaf3d9fb"},
"error":"rpc error: code = Unimplemented desc = unknown method GetUserFailedLoginInfoRequest for service vault.Replication"
Cause
This service error is to be expected when there is a Vault version discrepancy between the active and standby nodes.
Solution
We upgrade the standby first, thus it will have a different version than the active (for a time). Users may experience this error if a request is sent to the standby node and there is a discrepancy between active and standby. As a result, some downtime is to be expected. The optimum method to manage this would be to complete the upgrading processes (and checks) on each node as soon as possible to minimise downtime.
When all of the nodes are running the same version, the error disappears.
This does not apply if the storage backend is Consul. However, with Integrated Storage, which uses Autopilot to automate updates, the procedure is expedited.