Problem
After upgrading to a recent version of Terraform Enterprise (TFE), logged-in users may encounter an issue where the application fails to load. The user interface displays a blank, white screen, and a 500 error is shown in the browser console.
TFE administrators may also see the following error in the application logs:
{
"method": "GET",
"path": "/api/v2/organization-memberships",
"format": "jsonapi",
"status": 500,
"error": "JSON::ParserError"
}Prerequisites
- You are upgrading from TFE version
v202010-1or older. - You are upgrading directly to TFE
v202303-1or a later version.
Cause
This issue can occur when upgrading from TFE v202010-1 or earlier directly to TFE v202303-1 or later.
For security reasons, cookie marshaling was updated in TFE v202011-1 to use a more secure format. For a time, cookies for pre-existing sessions generated in the older, less secure format were still accepted by the application. TFE v202303-1 removed support for this older cookie format completely. Browsers retaining the old cookie format will fail to authenticate, resulting in the error.
Solutions
Solution 1: Clear Browser Cookies
The user experiencing the issue must clear the cookies for the Terraform Enterprise domain in their web browser.
Outcome
After clearing the cookies for the affected TFE application, functionality should be restored. Users should be able to log in and no longer see the blank screen.
Additional Information
- For guidance on upgrading Terraform Enterprise, please refer to the official upgrade documentation.