Introduction
For security reasons, cookie marshaling has been updated, and will no longer accept any cookies generated by TFE releases prior to v202011-1.
Problem
After upgrading to the latest version of TFE, logged in users may encounter an issue where TFE fails to load and where all that is shown is a blank, white screen and a `500` error displayed in the browser console. Additionally, TFE admins may see the following error in their application logs:
"method":"GET","path":"/api/v2/organization-memberships","format":"jsonapi","status":500,"error":"JSON::ParserError
Prerequisites
- Currently using TFE v202010-1 or older.
- Abruptly upgrading without spending at least a month on an intermediate version of TFE.
Cause
This may occur when upgrading from TFE v202010-1 or earlier directly to TFE v202303-1 or later, without spending at least a month on an intermediate version.
TFE v202010-1 updated the format of authentication cookies to a more secure format, but cookies for pre-existing sessions that were generated in the older, less secure format were still accepted by the application. TFE v202303-1 removed support for this older cookie format completely.
Solutions
This failure to load can be solved by clearing the cookies for the TFE domain in the affected user's web browser.
Outcome
Once the cookies have been cleared for the affected TFE applications, functionality should be restored and users should no longer see a failure to load and a blank, white screen.