Problem
When an account is invited to an HCP Terraform organization that enforces two-factor authentication (2FA/MFA) , the user may become stuck on the "2FA / MFA is required" page. This can prevent them from navigating to the user settings page to configure 2FA/MFA for their account.
Cause
This issue occurs due to a limitation in the HCP Terraform user interface that blocks access to other settings pages when an organization's 2FA/MFA requirement is pending for the user account.
Solution
This workaround uses your web browser's developer tools to temporarily block a specific network request, which allows you to access the 2FA/MFA configuration page.
Note: The following steps are for the Google Chrome web browser, but other browsers have similar developer tools and network request blocking features.
Procedure
In an incognito browser window, open the browser's Developer Tools. You can typically do this by selecting the ... menu, then More Tools, and then Developer Tools.
Navigate to the Network tab and click the More network conditions icon (three vertical dots).
At the bottom of the screen, select the Network request blocking tab and click the Add pattern button.
In the text box, enter the pattern
app.terraform.io/api/v2/organizations/*and click Add.- Without closing the Developer Tools window, enter
https://app.terraform.io/app/settings/two-factorin the URL bar and press Enter.
Outcome
This procedure should allow you to access the settings page to configure 2FA/MFA for your HCP Terraform account. After you complete the setup, you can close the developer tools and the incognito window. You should then be able to log in to HCP Terraform normally and accept the organization invitation.
Additional Information
For more details on security features, please refer to the official HCP Terraform documentation on two-factor authentication.