Problem
When attempting to apply a new replicated license file to Terraform Enterprise, it may fail silently. Upon navigating tohttps://TFE_HOSTNAME:8800/license
and clicking on Sync License, the following error can be found in docker logs replicated
:"Unable to sync license: Error: Internal Server Error"
Prerequisites
- Terraform Enterprise
Cause
- This issue occurs when the new license file is generated from a different Replicated account than the one that originally issued the current license.
Solutions:
There are two possible solutions for this issue:
- Re-create the TFE instance with the new license being used during initialization.
or - Reach out to your Customer Success Manager or Hashicorp Support to get an updated license file from the correct organization.