Problem
When installing or reinstalling Terraform Enterprise after a license has expired, the operation fails with the following error, even if the license is configured to ignore expiration dates for running instances.
License bootstrap failed: install license online: import license properties: license has expired
Cause
There are two primary causes for this issue:
- The Terraform Enterprise license setting to ignore expiration dates only applies to an already installed and running instance. Any new installation process, whether manual, through a pipeline, or via an auto-scaling group (ASG), will execute the
installer.shscript, which strictly enforces the license's expiration date. - Newer versions of Replicated, the underlying scheduler for some Terraform Enterprise installations, may prevent an instance from restarting or updating if its license is expired.
Solutions
To resolve this issue, you must obtain an updated license from your HashiCorp account team. The specific process depends on your installation type.
Solution 1: Online Installations
For online installations, your HashiCorp account team can extend the expiration date of your existing license if you have a valid sales agreement. Once the extension is applied, you can perform a license resynchronization from the Terraform Enterprise admin console to resolve the issue.
Solution 2: Air-gapped Installations
For air-gapped installations, your HashiCorp account team must provide a new license file with an updated expiration date. You must use this new file for any new installation or within your auto-scaling group configuration.