Terraform Enterprise Error: "Error saving SMTP settings Delivery Test Error" when updating SMTP credentials
Problem
When updating SMTP credentials in the Terraform Enterprise UI for an instance using an AWS SMTP server, the following error may occur.
Error saving SMTP settings Delivery Test Error
Prerequisites
- A Terraform Enterprise instance configured to use AWS IAM credentials to interact with an AWS SMTP server.
Cause
The error can occur if an AWS IAM secret access key is used in the password field instead of the correct AWS SMTP password.
Solution
To resolve the error, ensure you are using the correct SMTP password generated from the AWS Simple Email Service (SES) console, not your IAM secret access key.
- Check for a more descriptive error in the Terraform Enterprise container logs. For Terraform Enterprise version
v202205-1and later, check thetfe-atlascontainer. For earlier versions, check theptfe_atlascontainer. You can find instructions for viewing logs in the Terraform Enterprise SMTP Troubleshooting Guide. - If no specific errors appear in the logs, verify that you are using the correct credentials. Follow the AWS documentation on Obtaining your Amazon SES SMTP credentials to generate or confirm your SMTP password.
- Update the SMTP settings in the Terraform Enterprise UI with the correct SMTP password.