Introduction
When a Terraform Cloud workspace is connected to a VCS repository the repository contents are cloned each time a commit is pushed to the branch tracked by the workspace.
If the cloning process fails Terraform Cloud will display an error in the workspace and will not allow runs to be triggered in it as the associated Terraform configuration is out of sync with the VCS repository contents.
Problem
A workspace is displaying the error message "Internal error: SIC-001".
Cause
If the detailed error message starts with Failed to ingress slug: Failed to
fetch repo:
or similar this indicates that Terraform cloud was unable to clone the VCS repository that the workspace is connected to.
This can be due to:
-
Transient network failures.
-
Terraform Cloud not having access to the particular repository.
-
The repository does not exist e.g. it has been deleted or renamed
Solutions
Reading the detailed error message can help narrow down the possible causes. For example:
remote: Repository not found.
fatal: repository '<repository name>' not found
This error message indicates that the repository is not accessible or it does not exist.
exit status 128 Output: error: RPC failed; curl 56 OpenSSL SSL_read:
Connection reset by peer ...
This error message would most often be the result of a transient network failure.
To attempt to resolve this please confirm that:
- The VCS repository exists.
- Terraform Cloud has access to the repository via the configured VCS connection.
- The Terraform Cloud and your VCS provider status pages do not indicate any ongoing incidents that may affect cloning repositories.
Once the issues mentioned above are resolved or you feel that the problem may have been temporary you will need to make Terraform Cloud clone the VCS repository again.
To do that make another commit to the repository branch that is tracked by the Terraform Cloud workspace.
Outcome
When Terraform Cloud succeeds in cloning the VCS repository the error message in the workspace will disappear and it will be possible to trigger runs.
If you are unable to resolve the issue please contact support at tf-cloud@hashicorp.support or submit a ticket via our support portal.