Introduction
When trying to reset the password for HCP Terraform through the self-service link for Forgot password? you may receive the below error:
"Something went wrong. Please try again"
Cause
Network restrictions or blockage from the corporate firewall.
Workaround
To workaround the error message you can try to follow the reset password process from another device while being connected to another network.
Additional Information
For additional assistance please contact HashiCorp Support.