Problem
When you attempt to reset your HCP Terraform password using the "Forgot password?" link, you may encounter the following error message:
Something went wrong. Please try again
Cause
This error can occur if network restrictions, such as a corporate firewall or proxy, block the password reset request.
Solution
To resolve this issue, attempt the password reset process from a different device or network that is not subject to the same restrictions. For example, you can use a personal mobile device connected to a cellular network instead of a corporate laptop connected to an office network.