Problem
Some scenarios may cause a VCS connection to "break" or disconnect unexpectedly. This can lead to undesired outcomes within your workspaces. A recent feature addition to Reauthorize
a VCS connection has been provided with the goal of fixing broken VCS connected workspaces to allow webhook events to continue being received. However if a connection to a VCS repository for policy sets or private module registry is broken, this could fix them as well but this is not guaranteed.
Availability
- Feature is available on Terraform Cloud
- This feature is available on Terraform Enterprise since
v202211-1
.
Cause
Common reasons that could warrant the use of the Reauthorize
button:
- Token refresh issues
- Incorrect or revoked tokens on the VCS provider side
Notes:
We highly recommend only using this for already broken connections. The process works very similarly to revoking an existing connection and then reconnecting the connection back to the current organization.
Where this differs is that the existing workspaces that are connected via that specific VCS Client will remain connected. Rather than being disconnected when our existing Revoke Connection
button.
At this time, we would like to discourage using this to change the authorized user for non-broken connections, since permissions to repositories could potentially change.
Solution:
- Navigate to the Organization settings pane.
- Click on Providers under the Version Control subsection.
- Click the
Reauthorize
button next to the OAuth Token ID
Additional Information
-
If you continue to experience issues or have any questions, please contact HashiCorp Support.